华为Quidway自研以太网交换机开局指导书V1.0-20090625-B1_图文

资料编码 使用对象 编写部门 华为工程师、合作工程师 业务与软件技术服务部

产品名称 产品版本 资料版本

Quidway自研以太网交换机

V1.0

Quidway自研以太网交换机开局指导书
拟 审 审 批 制: 核: 核: 准: 孙崧铭 日 日 日 日 期: 期: 期: 期: 2009-05-20

华 为 技 术 有 限 公 司
版权所有 侵权必究

华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

修订记录
日期 2009-06-22 修订版本 V1.0 描述 完成 作者 孙崧铭、李达

华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开





第 1 章 Quidway 自研以太网交换机产品概述............................................................................. 1
1.1 S3300 以太网交换机概述 ...................................................................................................... 1 1.1.1 S3328TP-EI 三层交换机 ............................................................................................. 1 1.1.2 S3328TP-24S 三层交换机 .......................................................................................... 2 1.1.3 S3352P-EI 三层交换机 ............................................................................................... 2 1.1.4 S3352P-24S 三层交换机 ............................................................................................ 2 1.1.5 S3352P-48S 三层交换机 ............................................................................................ 3 1.2 S5300 以太网交换机概述 ...................................................................................................... 3 1.2.1 S5352C 三层交换机.................................................................................................... 4 1.2.2 S5328C-24S 三层交换机 ............................................................................................ 4 1.2.3 S5328C 三层交换机.................................................................................................... 4 1.3 S9300 以太网交换机概述 ...................................................................................................... 5 1.3.1 S9303 三层交换机 ...................................................................................................... 5 1.3.2 S9306 三层交换机 ...................................................................................................... 5 1.3.3 S9312 三层交换机 ...................................................................................................... 6

第 2 章 Quidway 局域网交换机数据准备 ................................................................................... 7
2.1 登录进入交换机 .................................................................................................................... 7 2.1.1 搭建配置环境 ............................................................................................................. 7 2.1.2 配置电缆连接 ............................................................................................................. 7 2.1.3 设置微机或终端的参数............................................................................................... 7 2.1.4 交换机上电 ............................................................................................................... 10 2.2 版本配套 ............................................................................................................................. 10 2.2.1 查看当前的软件版本 ................................................................................................ 10 2.3 软件版本升级 ...................................................................................................................... 11 2.3.1 BOOTROM 升级方法................................................................................................ 11 2.3.2 VRP 版本升级方法.................................................................................................... 14 2.4 配置规划 ............................................................................................................................. 15 2.4.1 网络拓扑图 ............................................................................................................... 15 2.4.2 系统名 ...................................................................................................................... 16 2.4.3 当地时区 .................................................................................................................. 16 2.4.4 接口分配 .................................................................................................................. 16 2.4.5 VLAN 规划 ................................................................................................................ 17 2.4.6 生成树规划 ............................................................................................................... 19 2.4.7 IP 地址规划 ............................................................................................................... 21 2.4.8 路由规划 .................................................................................................................. 21 2.4.9 远程维护登录帐号/口令和 Super 密码 ..................................................................... 23
华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

第 3 章 Quidway 局域网交换机配置 ......................................................................................... 23
3.1 时间日期和时区配置 ........................................................................................................... 23 3.2 系统名配置 ......................................................................................................................... 23 3.3 VLAN 配置 ........................................................................................................................... 24 3.3.1 功能需求和组网说明 ................................................................................................ 24 3.3.2 数据配置步骤 ........................................................................................................... 24 3.3.3 测试验证 .................................................................................................................. 26 3.4 端口的 Trunk 属性配置 ....................................................................................................... 26 3.4.1 功能需求和组网说明 ................................................................................................ 26 3.4.2 数据配置步骤 ........................................................................................................... 26 3.4.3 测试验证 .................................................................................................................. 28 3.5 IP 地址配置 ......................................................................................................................... 28 3.5.1 功能需求和组网说明 ................................................................................................ 28 3.5.2 数据配置步骤 ........................................................................................................... 29 3.5.3 测试验证 .................................................................................................................. 29 3.6 远程维护登录帐号/口令和 Super 密码配置......................................................................... 30 3.6.1 远程维护登录帐号/口令配置 .................................................................................... 30 3.6.2 Super 密码配置......................................................................................................... 30 3.7 端口汇聚配置 ...................................................................................................................... 31 3.8 镜像配置 ............................................................................................................................. 33 3.9 生成树配置 ......................................................................................................................... 35 3.9.1 交换机启动生成树 STP ............................................................................................ 35 3.9.2 指定生成树类型 ....................................................................................................... 35 3.9.3 指定生成树主根和备根............................................................................................. 35 3.9.4 对主备交换机级联接口调整端口路径花销................................................................ 35 3.9.5 与主机互联的端口配置为边缘端口 .......................................................................... 35 3.9.6 三层 VLAN 点对点方式互联端口关闭 STP 协议 ...................................................... 35 3.10 VRRP 配置 ........................................................................................................................ 36 3.10.1 功能需求和组网说明 .............................................................................................. 36 3.10.2 数据配置步骤 ......................................................................................................... 36 3.10.3 测试验证 ................................................................................................................ 39 3.11 静态路由配置 .................................................................................................................... 39 3.11.1 功能需求和组网说明 .............................................................................................. 39 3.11.2 数据配置步骤 ......................................................................................................... 40 3.11.3 测试验证 ................................................................................................................ 41 3.12 OSPF 配置 ........................................................................................................................ 41 3.12.1 功能需求和组网说明 .............................................................................................. 41 3.12.2 数据配置步骤 ......................................................................................................... 42 3.12.3 测试验证 ................................................................................................................ 47
华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

第 4 章 Quidway 局域网交换机基本维护 ................................................................................. 47
4.1 查看软件版本信息 .............................................................................................................. 47 4.2 系统配置文件维护 .............................................................................................................. 48 4.3 查看 CPU 占用率 ................................................................................................................ 48 4.4 查看内存占用率 .................................................................................................................. 49 4.5 查看日志缓冲区信息 ........................................................................................................... 50 4.6 查看路由表信息 .................................................................................................................. 51 4.7 查看 OSPF 状态 ................................................................................................................. 51 4.8 查看接口状态 ...................................................................................................................... 52 4.9 查看 MAC 地址表 ............................................................................................................... 53 4.10 查看 ARP 映射表 .............................................................................................................. 53 4.11 查看 VLAN 信息 ................................................................................................................ 54 4.12 查看生成树信息 ................................................................................................................ 55 4.13 查看 VRRP 信息 ............................................................................................................... 57 4.14 收集系统诊断信息 ............................................................................................................ 57

华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

关键词: Quidway, 交换机, 开局指导书



要: 本文结合业务与软件产品线工程师开局需要对华为 Quidway 局域网交换 机数据准备给出指导,并对其常见配置进行描述。满足业务与软件产品 常见组网应用开局配置需求。

缩略语清单: VRP GBIC SFP STP RSTP MSTP VRRP LACP 通用路由平台,Versatile Routing Platform Gigabit Interface Converter Small Form-Factor Pluggable 生成树协议,Spanning Tree Protocol 快速生成树协议,Rapid STP 多生成树协议,Multiple Spanning Tree Protocol Virtual Router Redundancy Protocol 链 路 聚 合 控 制 协 议 , Link Aggregation Control Protocol

(IEEE802.3ad)

参考资料清单: 《Quidway S3300 系列以太网交换机-操作手册》 《Quidway S3300 系列以太网交换机-命令手册》 《S3300 系列操作手册》

华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

第1章 Quidway 自研以太网交换机产品概述
面对网络 IP 化和三网合一的趋势,一方面城域以太网上承载的业务越来 越丰富,另一方面业务传输的质量要求越来越高。为了满足城域网对多 业务可靠接入和高质量传输的要求,华为公司推出了集接入、汇聚和传 送功能于一身的 Quidway 自研系列以太网交换机。 自研系列交换机基于成熟、经济的“IP 内核”的分组转发框架,可构建 高可靠的环网拓扑,具有多业务接入能力、良好的扩展性、QoS(Quality of Service)、强大的组播复制能力、运营级的安全性。 软件公司目前主要选型华为自产 S3300、S5300、S9300 局域网交换机 用于业务组网。

1.1 S3300 以太网交换机概述
Quidway? S3300 系列交换机,是华为公司为满足以太网多业务承载需 要而推出的新一代三层以太网交换机,可为运营商或企业客户提供强大 的以太网功能服务。 S3300 基于新一代高性能硬件和华为公司统一的 VRP?(Versatile Routing Platform)软件,提供增强型灵活 QinQ 功能, 具备线速的跨 VLAN 组播复制能力,支持 SmartLink(用于树型组网)和 RRPP(用于环形组网)等电信级可靠性组网技术,具备以太网 OAM 功 能,可满足楼宇接入、园区汇聚和接入等多种应用场景的需求。S3300 设备安装简便,支持自动配置,即插即用,显著降低客户网络部署成本。 S3300 系列交换机为盒式产品设备,机箱高度为 1U,提供标准型(SI) 和增强型(EI)两种产品版本,标准型支持二层和基本的三层功能,增强 型支持复杂的路由协议和丰富的业务特性,包含型号如下: S3328TP-SI/E1、S3328TP-EI-24S、S3328TP-PWR-EI、S3352P-SI、 S3352P-EI 、S3352P-EI-24S 、S3352P-EI-48S 、S3352P-PWR-EI 。软 件公司各产品线主要选型 S3328TP-EI、S3328TP-24S、S3352P-EI、 S3352P-24S、S3352P-48S。下面子章节仅介绍软件公司涉及到的交换 机。

1.1.1 S3328TP-EI 三层交换机
S3328TP-EI 提供 24 电接口、2 个 GE 光接口和 2 对 COMBO 接口,并 提供一个 Console 口用于本地配置。S3328 包括 1 个交换主控板称为 SCU(Switch Control Unit),支持 12.8Gbps 的交换能力。其前面板图 如下所示:
2009-06-28 华为机密,未经许可不得扩散 第 1 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图1-1 S3328TP-EI 交换机前面板示意图

S3328TP-EI 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.1.2 S3328TP-24S 三层交换机
S3328TP-24S 为 24 光接口、2 个 GE 光接口和 2 对 COMBO 接口,并 提供一个 Console 口用于本地配置。S3328 包括 1 个交换主控板称为 SCU(Switch Control Unit),支持 12.8Gbps 的交换能力。其前面板图 如下所示:

图1-2 S3328TP-24S 交换机前面板示意图

S3328TP24S 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.1.3 S3352P-EI 三层交换机
S3352P-EI 为 48 个电接口、2 个 GE 光接口和 2 对 GE/FE 光接口,并 提供一个 Console 口用于本地配置。S3352 包括 1 个交换主控板称为 SCU(Switch Control Unit),支持 17.6Gbps 的交换能力。其前面板图 如下所示:

图1-3 S3352P-E 交换机前面板示意图

S3352P- EI 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.1.4 S3352P-24S 三层交换机
S3352P-24S 为 24 光接口和 24 个电接口、 2 个 GE 光接口和 2 对 GE/FE 光接口,并提供一个 Console 口用于本地配置。S3352 包括 1 个交换主 控板称为 SCU(Switch Control Unit),支持 17.6Gbps 的交换能力。其 前面板图如下所示:

2009-06-28

华为机密,未经许可不得扩散

第 2 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图1-4 S3352P-24S 交换机前面板示意图

S3352P-EI-24S 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.1.5 S3352P-48S 三层交换机
S3352P-48S 为 48 光接口、2 个 GE 光接口和 2 对 GE/FE 光接口,并提 供一个 Console 口用于本地配置。 S3352 包括 1 个交换主控板称为 SCU (Switch Control Unit),支持 17.6Gbps 的交换能力。其前面板图如下 所示:

图1-5 S3352P-48S 交换机前面板示意图

S3352P-SI/EI-48S 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.2 S5300 以太网交换机概述
Quidway? S5300 系列全千兆交换机,是华为公司为满足大带宽接入和 以太网多业务汇聚而推出的新一代全千兆以太网交换机。可为客户提供 强大的以太网功能服务。S5300 基于新一代高性能硬件和华为公司统一 的 VRP?(Versatile Routing Platform)软件,具备大容量、高密度千兆 端口,同时可提供万兆上行能力,可以充分满足客户对高密度千兆和万 兆上行设备的需求。S5300 可满足运营商园区网汇聚、企业网汇聚、IDC 千兆接入以及企业千兆到桌面等多种场合的需求。 S5300 系列以太网交换机为盒式设备, 机箱高度为 1U, 提供标准型 (SI) 和增强型(EI)两种产品版本。标准型支持二层和基本的三层功能,增强 型支持复杂的路由协议和丰富的业务特性,包含型号如下: S5324TP-SI/PWR-SI 、 S5328C-SI/EI 、 S5328C-PWR-SI/PWR-EI 、 S5328C-EI-24S 、 S5348TP-SI/PWR-SI 、 S5352C-SI/EI 、 S5352C-PWR-SI/PWR-EI 。 软 件 公 司 各 产 品 线 主 要 选 型 S5352C 、 S5328C-24S、S5328C。下面子章节仅介绍软件公司涉及到的交换机。

2009-06-28

华为机密,未经许可不得扩散

第 3 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

1.2.1 S5352C 三层交换机
S5352C 设备提供 48 个 GE 接口、2 个电源插槽、1 个扩展插槽,并提 供一个 Console 口用于本地配置和一个管理网口。S5352C 包括 1 个交 换主控板称为 SCU(Switch Control Unit),支持 136Gbps 的交换能力。 其前面板图如下所示:

图1-6 S5352C 交换机前面板示意图

S5352C 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.2.2 S5328C-24S 三层交换机
S5328C-24S 设备提供 24 个 GE 光接口和 4 个 COMBO 接口、 2 个电源 插槽、1 个扩展插槽,并提供一个 Console 口用于本地配置和一个管理 网口。 S5328C-24S 包括 1 个交换主控板称为 SCU (Switch Control Unit) , 支持 88Gbps 的交换能力。其前面板图如下所示:

图1-7 S5352C 交换机前面板示意图

S5328C-24S 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

1.2.3 S5328C 三层交换机
S5328C 设备提供 24 个 GE 接口、2 个电源插槽、1 个扩展插槽,并提 供一个 Console 口用于本地配置和一个管理网口。S5328C 包括 1 个交 换主控板称为 SCU(Switch Control Unit),支持 88Gbps 的交换能力。 其前面板图如下所示:

图1-8 S5328C 交换机前面板示意图

S5328C 机 箱 高 度 为 1U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?220.0mm?43.6mm(宽?深?高)。

2009-06-28

华为机密,未经许可不得扩散

第 4 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

1.3 S9300 以太网交换机概述
Quidway? S9300 系列 T 比特路由交换机是华为公司面向以业务为核心 的网络架构而推出的新一代高端以太汇聚交换机。该产品基于华为公司 智能多层交换的技术理念,在提供稳定、可靠、安全的高性能 L2/L3 层 交换服务基础上,进一步提供业务流分析、完善的 QOS 策略、可控组播 等智能业务优化手段,同时具备超强扩展性和可靠性,广泛适用于运营 商 IP 城域网,企业广域网/城域网,企业出口/核心/汇聚,高密度千兆桌 面接入,以及数据中心,帮助电信运营商和企业构建面向业务的网络平 台,提供交换路由一体化的端到端融合网络服务。 S9300 系列提供 4 插槽、8 插槽、14 插槽三种产品形态,支持不断扩展 的交换能力和端口密度。整个系列秉承模块通用化、部件归一化的设计 理念,最小化备件成本,在保证设备扩展性的同时最大限度地保护用户 投资。此外,S9300 作为新一代智能交换机采用了多项绿色节能创新技 术,不断提升性能及稳定性的同时,大幅降低设备能源消耗,减小噪声 污染,为网络绿色可持续发展提供领先的解决方案。软件公司各产品线 主要选型 S9303、S9306、S9312。下面子章节仅介绍软件公司涉及到的 交换机。

1.3.1 S9303 三层交换机
S9303 模块化交换机提供 3 个业务线卡槽位、2 个主控槽位、2 个电源槽 位。其前面板图如下所示:

图1-9 S9303 交换机前面板示意图

S9303 机 箱 高 度 为 4U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?476.0mm?175mm(宽?深?高)。

1.3.2 S9306 三层交换机
S9306 模块化交换机提供 6 个业务线卡槽位、2 个主控槽位、4 个电源槽 位、2 个监控卡槽位。其前面板图如下所示:

2009-06-28

华为机密,未经许可不得扩散

第 5 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图1-10 S9306 交换机前面板示意图

S9306 机 箱 高 度 为 10U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?476.0mm?442mm(宽?深?高)。

1.3.3 S9312 三层交换机
S9312 模块化交换机,提供 12 个业务线卡槽位、2 个主控槽位、4 个电 源槽位、2 个监控卡槽位。其前面板图如下所示:

图1-11 S9312 交换机前面板示意图

S9312 机 箱 高 度 为 15U ( 1U=44.45mm ) , 外 型 尺 寸 为 442.0mm?476.0mm?664mm(宽?深?高)。

2009-06-28

华为机密,未经许可不得扩散

第 6 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

第2章 Quidway 局域网交换机数据准备
2.1 登录进入交换机
2.1.1 搭建配置环境
第一次安装使用 Quidway 交换机时,只能通过配置口(Console)进行 配置。

图2-1 交换机配置连接示意图

2.1.2 配置电缆连接
第一步:将配置电缆的 DB-9(或 DB-25)孔式插头接到要对交换机进行 配置的微机或终端的串口上。 第二步:将配置电缆的 RJ-45 一端连到交换机的配置口(Console)上。

2.1.3 设置微机或终端的参数
第一步:打开微机或终端。 如果使用微机进行配置,需要在微机上运行终端仿真程序,如 Windows 的超级终端。 第二步:设置终端参数。 参数要求: 设置波特率为 9600,数据位为 8,奇偶校验为无,停止位为 1,流量控 制为无,选择终端仿真为 VT100。 WindowsXP 超级终端参数设置方法如下: (1) 在下图所示的超级终端窗口中,单击其[属性]按钮。

2009-06-28

华为机密,未经许可不得扩散

第 7 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-2 超级终端配置方法

(2) 在超级终端属性对话框中[连接时使用]一栏选择连接的串口。选择的 串口应该与配置电缆接的串口一致。单击[配置]按钮。

图2-3 超级终端属性设置

(3) 在串口的属性对话框中设置波特率为 9600,数据位为 8,奇偶校验 为无,停止位为 1,流量控制为无。单击[确定]按钮。

2009-06-28

华为机密,未经许可不得扩散

第 8 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-4 超级终端 COM 口属性设置

(4) 在超级终端属性对话框中选择[设置]一项,进入下图所示的属性设置 窗口。选择终端仿真为 VT100, 单击[确定]按钮。

2009-06-28

华为机密,未经许可不得扩散

第 9 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-5 超级终端终端仿真设置

2.1.4 交换机上电
确认交换机与配置终端的连接正确,确认已经完成配置终端参数的设置 后,即可对交换机上电。随后交换机上出现自检内容。 启动完毕,回车,超级终端里显示<Quidway>字样。即可进行下一步的 配置。

2.2 版本配套
Quidway S 系列交换机对 VRP 软件和 BOOTROM 软件有版本配套要求, 当前最新版本配套如下:
型号 S3328TP-EI/S3328TP-S I/S3328TP-EI-24S S3352P-SI/S3352P-EI-2 4S/S3352P-EI-48S S5328C-EI/S5328C-EI-2 4S/S5352C-EI S9303/S9306/S9312 内存需求 128M 128M 128M 128M FLASH 需求 16M 16M 16M 16M VRP 版本号 V100R002C02B181SPC001_for_3 328.CC SV100R002C02B181SPC001_for _2352_3352.CC SV100R002C02B181SPC001_for _5300.CC V100R001C02-SPH005 BOOTROM 版本号 308 204 006 103

2.2.1 查看当前的软件版本
查看当前的软件版本是进行软件升级,定位问题的前提。

查看当前的版本命令是:<Quidway>display version 输出信息示例如下:
<Quidway> display version Huawei Versatile Routing Platform Software VRP (R) Software, Version 5.30 (S3300 V100R001C03B132) Copyright (C) 2007-2008 Huawei Technologies Co., Ltd. Quidway S3328TP-EI uptime is 3 days, 15 hours, 24 minutes [Slot 0] EOFEA uptime is 3 days, 15 hours, 24 minutes Startup time :2008/01/01 00:00:03 128M bytes DDR Memory 16M bytes FLASH Pcb Version : CX22EOFEA REV A Basic BOOTROM Version : 303 Compiled at Nov 6 2008, 16:08:08

2009-06-28

华为机密,未经许可不得扩散

第 10 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Software Version : VRP (R) Software, Version 5.30 (S3300 V100R001C03B132) 上述红色字体分别为交换机型号和软件版本号

注意:
(1)上表版本配套截至日期为 2009-6-15,最新版本请通过当地数通工程师或数通接 口人获取。

(2)在开局过程中建议交换机的版本为最新版本,并且对冗余配置的交换 机主备设备之间要求版本一致。

2.3 软件版本升级
如果交换机软件版本达不到组网网元配套要求(比如,主备机版本不一 致,当前版本存在缺陷或者跟其他网元存在配合问题),则需要进行软 件版本升级。版本获取方式通过当地数通工程师或数通接口人获取。根 据软件的配套要求进行 BOOTROM 升级和 VRP 版本升级。

2.3.1 BOOTROM 升级方法
(一) 重启设备 进入 BootROM 系统菜单前, 用户需要先重新启动设备。 设备在开始启动 时,屏幕显示如下信息。 Press Ctrl+B to enter BOOTROM menu... 3 请在 3 秒内按下“Ctrl+B”,正确输入密码(缺值密码是 huawei)后, 进入 BootROM 系统菜单。屏幕显示如下信息。
BOOTROM MENU 1. Boot with default mode 2. Enter serial submenu 3. Enter startup submenu 4. Display flash files 5. Modify BOOTROM password 6. Reboot Enter your choice(1-6):

(二) 进入升级子系统
选择“2. Enter serial submenu”,屏幕显示如下信息 SERIAL SUBMENU 1. Update BOOTROM system 2. Download file to Flash through serial interface 3. Modify serial interface parameter

2009-06-28

华为机密,未经许可不得扩散

第 11 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4. Return to main menu

(三) 更改串口参数

更改串口传输速率后,会造成 PC 与设备之间的通信短暂中断。您需要将 PC 上的串口传输速率与设备上的串口传输速率设置为一致, 才能恢复 PC 与设备之间的串口通信。 选择“3. Modify serial interface parameter”,屏幕显示如下信息。
Enter your choice(1-5): 3 1: 9600(default) 2: 19200 3: 38400 4: 57600 5: 115200 please select an appropriate baudrate: Enter your choice(1-5):

请根据实际情况选择串口传输速率,串口传输速率的单位是 bit/s。设备 的缺省串口传输速率是 9600bit/s。用户选择的值越大,则串口传输速率 越高,建议用户选择“5: 115200”。 在更改设备的串口传输速率后, 为恢复 PC 与设备之间的串口通信, 请将 PC 的串口传输速率设置为与设备的串口传输速率相同的值。 例如选择“5: 115200”后,屏幕显示如下信息。
BaudRate is 115200 bps. Please change the terminal's speed to 115200 bps

此时, 需要在超级终端中按照以下顺序进行设置, 才能恢复 PC 与设备之 间的串口通信:
? ? ? ? ? ?

选择超级终端的“呼叫/断开”菜单项后断开连接。 选择“文件/属性”菜单项,弹出“属性”对话框。 单击“连接到”页签中的“配置”按钮,弹出“COM 属性”对话框。 选择“每秒位数”下拉列表框中的“115200”选项。 单击“COM 属性”对话框和“属性”对话框的“确定”按钮。 选择超级终端的“呼叫/呼叫”菜单项后重新建立连接。

(四) 升级 BootROM 系统软件

2009-06-28

华为机密,未经许可不得扩散

第 12 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

不同系列产品的 bootrom 不能互相兼容, 如: 严禁使用 S2300 的 BootROM 系统软件对 S3300 的 BootROM 进行升级!同样,也不能使用 S3300 的 BootROM 对 S2300 的 BootROM 进行升级!同系列中的小系列之间也不 能互相兼容,如 3328 系列与 3352 系列的不能兼容。 选择“1. Update BOOTROM system”,屏幕显示如下信息。
Enter your choice(1-5): 1 Please Select File . XMODEM downloading ...CC

此时,选择超级终端的“传送/发送文件”菜单项,弹出“发送文件”对 话框,如下图所示。

点 击 “ 浏 览 ” 按 钮 , 选 择 BootROM 系 统 软 件 的 升 级 文 件 “bootrom308.bin”。

请确保选择的文件是对应的系列的 BootROM 系统软件! 在“协议”下拉列表框中,选择“XMODEM”。点击“发送”按钮,开 始传输升级文件。 当升级文件传输完成后,屏幕显示如下信息。
XMODEM downloading ...CC download to SDRAM successfully

然后,设备使用此升级文件自动升级 BootROM 系统软件。升级完成后,设备自动返回 BootROM 系统菜单。

2009-06-28

华为机密,未经许可不得扩散

第 13 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

2.3.2 VRP 版本升级方法
本文仅介绍 VRP 版本采用 CLI FTP 方式的升级方法,交换机作为 FTP server。 (一) 设置设备为 FTP 服务器 在 S-switch 上启动 FTP 服务, 并配置 FTP 用户名 ftpuser, 口令 ftppwd。
<Quidway> system-view [Quidway] ftp server enable [Quidway] aaa [Quidway-aaa] local-user ftpuser password simple ftppwd [Quidway-aaa] local-user ftpuser service-type ftp [Quidway-aaa] local-user ftpuser ftp-directory flash:/ [Quidway-aaa] return

(二) 配置设备 IP
<Quidway> system-view [Quidway] vlan 10 [Quidway-vlan10] port ethernet 0/0/1 [Quidway-vlan10] quit [Quidway] interface vlanif 10 [Quidway-Vlanif10] ip address 1.1.1.1 24 [Quidway-Vlanif10] quit 空闲业务网口

(三) 登录 FTP 服务器(S-switch) 在 PC 上执行 ftp ip-address 命令,与设备建立 FTP 连接,并进行 FTP 客户端视图。
D:\>ftp 1.1.1.1 Connected to 1.1.1.1. 220 FTP service ready. User (192.168.100.105:(none)): ftpuser 331 Password required for 1. Password: 230 User logged in. ftp>

(四) 下载 S3300 产品系统软件,以 S3328 为例,下同。 在 FTP 客户端 (PC) 上执行 put source-filename [ destination-filename ], 从 PC 上传 VRP 系统软件。上传结束后,执行 bye 命令,断开 ftp 连接, 返回用户视图。
2009-06-28 华为机密,未经许可不得扩散 第 14 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

ftp> put "D:\SV100R002C02B181SPC001_for_3328.cc" 200 Port command okay. 150 Opening ASCII mode data connection for SV100R002C02B181SPC001_for_3328.cc. 226 Transfer complete. ftp: 发送 4940436 字节,用时 35.10Seconds 140.76Kbytes/sec. ftp> bye 221 Server closing.

D:\>

(五) 在线升级设备启动时加载的 BootROM
<Quidway> system-view [Quidway] upgrade basic-bootrom SV100R002C02B181SPC001_for_3328.cc Confirm basic BOOTROM will be upgrade?(Y/N)[N]: y BOOTROM begin to upgraded ! please wait for a minute... BOOTROM UPGRADE OK The new version is 308. Please restart to validate the upgrade.

(六) 在线指定设备启动时加载的 VRP 系统软件
<Quidway>startup system-software SV100R002C02B181SPC001_for_3328.cc

(七) 重新启动交换主控板
<Quidway> reboot Info: The system is now comparing the configuration, please wait. Info: Save current configuration?[Y/N]: System will reboot! Continue?[Y/N]: 根据需要选择 y 或 n 根据需要选择 y 或 n

2.4 配置规划
在对交换机配置之前,需要完成如下基本配置规划:

2.4.1 网络拓扑图
网络拓扑图是进行规划和配置的基础,在开局时应该具备具体到网络设 备物理接口口的分配和连接的网络物理拓扑图。典型网络拓扑图示例如 下。

2009-06-28

华为机密,未经许可不得扩散

第 15 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-6 典型网络拓扑图

2.4.2 系统名
如果客户有自己的命名规则,按照客户的规则设置主机名;如果没有, 按规范(节点代码-局点缩写-设备名-设备序列号(1、2、3 等,主机添加 A(Active)后缀,备机添加 B(Backup)后缀)。如:广州 OCS 第一台主用 交换机 Quidway S3328EI 应填写:GZ-OCS-S3328EI-1A。

2.4.3 当地时区
在配置交换机时,需要配置交换机时间和时区,其中时区为当地时区信 息,比如,中国时区名为“Beijing”,GMT+08:00。

2.4.4 接口分配
根据交换机接口数量和业务对交换机端口的需求,对交换机接口连接进 行相应规划,接口分配举例参见下图。

2009-06-28

华为机密,未经许可不得扩散

第 16 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-7 接口规划表

2.4.5 VLAN 规划
组网的 VLAN 分配方法如下: 1、VLAN 划分以子网划分为标准,每个子网属于一个单独的 VLAN。 2、从管理和维护清晰方便的角度考虑,使用全局 VLAN 的概念。整个业 务网络内为每个子网分配完全独立的 VLAN ID, 所有 VLAN ID 不相重叠。 3、业务 VLAN 不使用 VLAN1,VLAN1 在某些交换机中有特殊的用途, 所以所有业务 VLAN 都不属于 VLAN1,即使在某些二层交换机中只有 1 个 VLAN,也必须为其分配独立的非 1 ID。 4、VLAN2 - VLAN9 为核心层互联 VLAN 和管理 VLAN,在核心交换 机上分配。对于没有单设核心交换机的小型局点,VLAN2 – VLAN 9 用 于交换机和其他系统互联,比如连接 Internet 防火墙等。 5、VLAN10 - VLAN99 为核心层与接入层互联 VLAN,其中双数为主 互联 VLAN,用于 1 号设备之间的互联;单数为备互联 VLAN,用于 2 号 设备之间的互联。对于没有单设核心交换机的小型局点, VLAN10 - VLAN99 用于局域网内交换机互联。 6、 VLAN100 - VLAN499 为业务主 VLAN, 每个业务预留 10 个 VLAN, 预留多个 VLAN 是为了有利于复杂子业务的内部组网 VLAN 分配。 如 WIN 为 VLAN100,MMS 为 VLAN110,……。UM 主业务网段为 VLAN140,
2009-06-28 华为机密,未经许可不得扩散 第 17 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

UM 的负载均衡服务器网段为 VLAN141 , UM 的 AIP 业务网段为 VLAN142,……如此类推。 7、VLAN500 – VLAN 999 为外围 VLAN。主要用于业务外围区域,比如 NMSVLAN、OSS VLAN 等对外连接。 VLAN 规划典型举例如下:
VLAN CORE CORE-Internet CORE-Intranet WIN USAU-1 CORE-WIN1 CORE-WIN2 MMS CORE-MMS1 CORE-MMS2 GMLC CORE-GMLC1 CORE-GMLC2 STREAM VM CORE-STREAM 1 CORE-STREAM 2 UM UM-LB UM-AIP CORE-UM1 CORE-UM2 DSMP CORE-DSMP1 CORE-DSMP2 WING CORE-WING1 CORE-WING2 USSD USAU-2 CORE-USSD1
2009-06-28

VLAN ID 2 3 5 100 101 10 11 110 12 13 120 14 15 130 131 16 17 140 141 142 18 19 150 20 21 160 22 23 170 171 24

Remark Inter-connect with 2 core switch S6506 Inter-connect with S6506 and Internet Firewall Eudemon 500 Inter-connect with S6506 and Intranet Firewall Eudemon 500 WIN VLAN USAU-1 VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G MMS VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G GMLC VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G STREAM VLAN VM VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G UM VLAN UM-LB VLAN UM-AIP VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G DSMP VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G WING VLAN Inter-connect with S6506 and edge switch S3528G Inter-connect with S6506 and edge switch S3528G USSD VLAN USAU-2 VLAN Inter-connect with S6506 and edge switch S3528G
华为机密,未经许可不得扩散 第 18 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

2.4.6 生成树规划
生成树协议(Spanning Tree Protocol,STP)可应用于环路网络,通过 一定的算法实现路径冗余,同时将环路网络修剪成无环路的树型网络, 从而避免报文在环路网络中的增生和无限循环。华为最新型号交换机支 持 MSTP,MSTP 向后兼容 RSTP 和 STP。 业务与软件组网中交换机互联建议建立在三层隔离的基础之上,所以生 成树(STP)设计覆盖的范围很小,仅仅局限在每一个独立业务的内部。 生成树规划主要有如下几种典型应用: ? ? 单层交换机互联 二层交换机互联

单层交换机互联 业务网络生成树范围最多只有 2 台交换机,不会形成物理的环路。

图2-8 单层交换机互联示意图

单层交换机互联方式建议进行如下 STP 设置: ? ? 在交换机中启用 STP,规避通信环路。 与主机互联的端口配置为边缘端口(edged-port)。所有确定与主机互 联的端口都应配置为边缘端口,这样的配置有利于主机与网络设备 的稳定快速的协商,减少不必要的网络流量,也大大减轻了网络设 备计算 STP 的资源消耗。 二级交换机互联 二级交换机互联典型连接方式为: 1、2 台 WIN 业务交换机和 2 台 USAU 交换机形成“口”字型连接。 2、2 台 SMS 业务交换机和 2 台 USAU 交换机形成“口”字型连接。

2009-06-28

华为机密,未经许可不得扩散

第 19 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

图2-9 二级交换机互联示意图

将 SWA 设为主根,将 SWB 设为备根,SWC 和 SWD 的 STP 优先级不 做任何更改(缺省为 32768),在 SWD 的与 SWC 互联的端口上,将 STP 的 cost 设置为 10,这样 STP 会收敛成一个开口的“口”字型,正 常情况下 SWB 和 SWD 互联的链路为阻断状态。 当主用的 SWA 和 SWC 之间链路或他们设备本身出现故障时,SWB 和 SWD 互联的链路才会由 于 STP 拓扑重新计算而连通,实现冗余。

二级交换机互联方式建议进行如下 STP 设置: ? ? 在交换机中启用 STP,规避通信环路。 指定生成树主根和备根。 在图 2-9 互联主备三层交换机 SWA 和 SWB 分别设为主根 (Primary root, 优先级为 0) 和备根 (Secondary root, 优先级为 4096),其他生成树的 STP 优先级不做任何更改(缺省 优先级为 32768)。 注意: (1) ? 在同一棵生成树实例中不能指定两个或两个以上的根交换机。 调整端口路径花销,确保主备交换机互联端口处于转发状态.下表不 同端口速率与 STP COST 的对应表。华为交换机端口速率与 STP cost 值对应表。 一般情况下我们在百兆和千兆端口下都推荐将 COST 值修改为 10。
链路速率 10Mb/s 100Mb/s 1Gb/s 10G/s 10G/s 以上 2009-06-28 推荐值 2,000 200 20 2 1 推荐取值范围 200- 20000 20-2000 2-200 2-20 1-2 华为机密,未经许可不得扩散 值域 1-200000 1-200000 1-200000 1-200000 1-200000 第 20 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

? ?

与主机互联的端口配置为边缘端口。 三层 VLAN 点对点方式互联端口关闭 STP 协议。

2.4.7 IP 地址规划
二层交换机只能配置一个三层虚接口,二层交换机中三层虚接口配置 IP 地址主要用于管理用途,不能用于三层报文转发功能。三层交换机可以 配置多个三层虚接口。交换机 IP 地址规划主要针对三层交换机。 IP 地址规划举例如下表:
表2-1 IP 地址规划表 SYSNAME/ MODLE S3328EI-1A INTERFACE Vlan-interface 13 Vlan-interface 100 Vlan-interface 140 Vlan-interface 160 IP ADDRESS/ NETMASK 10.140.24.78/30 10.140.25.29/27 10.140.25.253/26 Remark Connect to Core switch; P2P L3 VLAN VRRP IP: 10.140.25.30; WIN VLAN VRRP IP: 10.140.25.254;iGame VLAN VRRP IP: 10.140.26.30; MDSP External VLAN

10.140.26.29/27

2.4.8 路由规划
二层交换机只能配置静态路由,无法配置动态路由协议。三层交换机可 以配置动态路由协议。 在业务与软件组网中主要使用 OSPF 动态路由协议和静态路由相结合。 静态路由规划 静态路由规划示例如下表。

2009-06-28

华为机密,未经许可不得扩散

第 21 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Dst Net/Mask 0.0.0.0/0 10.0.0.165/32 10.199.10.1/32 63.173.173.242/32

Next hop 192.168.16.254 10.200.253.5 10.200.253.5 10.200.253.5

Routing Protocol static static static static

Preference 60 60 60 60

Description Default route XXX host route

OSPF 动态路由规划 在使用 OSPF 路由时,请综合考虑以下 OSPF 路由规划原则: 1、 核心交换机放置在 Area 0 域内。在较小规模的组网中可以将所有设 备属于 Area 0 中。 2、 其他区域必须直接和 Area 0 域相连; 3、 如果遇到某一区域不能直接和 Area 0 域直连, 则必须配置虚拟链路; 4、 默认路由必须放置在 Area 0 域内; 5、 规划路由时尽量保证同一区域的路由能聚合; 6、 请务必为每台运行 OSPF 的设备配置 router id。Router id 可以是设 备的 loopback 接口地址也可以是局域网接口 IP 地址。 7、 在做静态路由、直连路由引入到 OSPF 中时,需要在自治系统边界 引入,不要在区域内部重复引入,避免导致路由环路。 OSPF 动态路由区域规划示例如下表:
Net/Mask 0.0.0.0 192.168.100.0/24 172.16.8.0/24 10.0.0.0/24 10.199.10.0/24 10.11.0.0/24 63.173.173.0/24 Routing Protocol STATIC OSPF STATIC OSPF OSPF OSPF OSPF Area 0 0 0 0 1 2 3 Description To Internet To firewall XXX net route XXX net route

2009-06-28

华为机密,未经许可不得扩散

第 22 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

2.4.9 远程维护登录帐号/口令和 Super 密码
对交换机远程维护时登录方式要求基于帐号/口令方式访问,登录帐号的 用户优先级为 1 级(监控级),并要求配置 3 级(管理级)Super 口令。

第3章 Quidway 局域网交换机配置
本文通过典型配置方式对业务与软件常用的交换机配置进行描述。

3.1 时间日期和时区配置
时间设置应与当地时间一致(时间差不大于 0.5 小时),使用在用户视图 或者系统视图中 display clock 命令查看当前时间日期和时区设置。 命令 举例如下:
<Quidway>display clock 2008-01-01 22:24:41 Tuesday Time Zone : Dopra Default Zone Name add 00:00:00

如果系统时间不精确,在用户视图配置时区和时间。命令示例如下:
<Quidway>clock timezone beijing add 08:00:00 //设置时区 <Quidway>clock datetime 15:16:30 2009-06-11 //设置时间和日期

其中,beijing 表示时区名,08:00:00 表示当地时区与北京时区的差值, 15:16:30 表示当前时间,2009-06-11 表示当前日期。 配置完成后,使用 display clock 命令检查当前时间日期和时区配置,举 例如下:
<Quidway>display clock 2009-06-11 07:21:37 Thursday Time Zone : beijing add 08:00:00

3.2 系统名配置
网络设备系统名是设备的标识,在配置过程中要保证唯一性。如果客户 有自己的命名规则,按照客户的规则设置主机名;如果没有,按规范(节 点代码-局点缩写-设备名-设备序列号(1、2、3 等,主机添加 A(Active) 后缀,备机添加 B(Backup)后缀)。如:广州多媒体消息中心第一台主用 交换机 Quidway S3328TP 应填写:GZ-MMS-S3328TP-1A。
2009-06-28

华为机密,未经许可不得扩散

第 23 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Quidway 交换机支持系统名长度为 1 – 30 字节。系统名配置举例如下:
<Quidway>system-view // 进入系统视图

System View: return to User View with Ctrl+Z. [Quidway]sysname GZ-MMS-S3328TP-1A [GZ-MMS-S3328TP-1A] //系统提示符为更新后的系统名

3.3 VLAN 配置
VLAN(Virtual Local Area Network),是一种通过将局域网内的设备逻 辑地而不是物理地划分成一个个网段从而实现虚拟工作组的技术。IEEE 于 1999 年颁布了用以标准化 VLAN 实现方案的 IEEE 802.1Q 协议标准 草案。 VLAN 技术允许网络管理者将一个物理的 LAN 逻辑地划分成不同的广播 域(或称虚拟 LAN,即 VLAN),每一个 VLAN 都包含一组有着相同需 求的计算机, 由于 VLAN 是逻辑地而不是物理地划分, 所以同一个 VLAN 内的各个计算机无须被放置在同一个物理空间里,即这些计算机不一定 属于同一个物理 LAN 网段。 VLAN 的优势在于 VLAN 内部的广播和单播流量不会被转发到其它 VLAN 中,从而有助于控制网络流量、减少设备投资、简化网络管理、提高网 络安全性。

3.3.1 功能需求和组网说明

图3-1 VLAN 配置示意图

把交换机上的端口 E0/0/1 加入到 VLAN2 ,E0/0/2 加入到 VLAN3。

3.3.2 数据配置步骤
VLAN 配置有两种方法,方法一适合在 VLAN 视图中一次添加多个端口 到一个 VLAN 中。方法二适合对指定接口所属 VLAN 进行修改。
2009-06-28 华为机密,未经许可不得扩散 第 24 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

方法一 1. 2. 3. 4. 创建(进入)vlan2 将端口 E0/0/1 加入到 vlan2 创建(进入)vlan3 将端口 E0/0/2 加入到 vlan3

[SwitchA]vlan 2

[SwitchA-vlan2]port ethernet 0/0/1

[SwitchA-vlan2]vlan 3

[SwitchA-vlan3]port ethernet 0/0/2

方法二 1. 创建(进入)vlan2 进入端口 E0/0/1 视图 指定端口 E0/0/1 属于 vlan2 创建(进入)vlan3 进入端口 E0/0/2 视图 指定端口 E0/0/2 属于 vlan3

[SwitchA]vlan 2

2.

[SwitchA]interface ethernet 0/0/1

3.

[SwitchA-Ethernet0/0/1]port default vlan 2

4.

[SwitchA]vlan 3

5.

[SwitchA]interface ethernet 0/0/2

6.

[SwitchA-Ethernet0/0/2]port default vlan 3

?

说明:

(1) 缺省情况下所有端口都属于 VLAN 1,并且端口是 access 端口,一 个 access 端口只能属于一个 vlan; (2) 如果端口是 access 端口,则把端口加入到另外一个 vlan 的同时, 系统自动把该端口从原来的 vlan 中删除掉; (3) 除了 VLAN1, 如果 VLAN XX 不存在, 在系统视图下键入 VLAN XX, 则创建 VLAN XX 并进入 VLAN 视图;如果 VLAN XX 已经存在,则进入 VLAN 视图。

2009-06-28

华为机密,未经许可不得扩散

第 25 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.3.3 测试验证
1. 使用命令 display current-configuration 可以看到端口 E0/0/1 属于

vlan2,E0/0/2 属于 vlan3; 2. 使用 display interface Ethernet 0/0/1 可以看到端口为 access 端口, PVID 为 2; 3. 使用 display interface Ethernet 0/0/2 可以看到端口为 access 端

口,PVID 为 3。

3.4 端口的 Trunk 属性配置
3.4.1 功能需求和组网说明

图3-2 端口的 Trunk 属性配置示意图

配置环境参数 1. SwitchA 端口 E0/0/1 属于 vlan2,E0/0/2 属于 vlan3,E0/0/3 与

SwitchB 端口 E0/0/3 互连 2. SwitchB 端口 E0/0/1 属于 vlan2,E0/0/2 属于 vlan3,E0/0/3 与

SwitchA 端口 E0/0/3 互连 组网需求 1. 2. 要求 SwitchA 的 vlan2 的 PC 与 SwitchB 的 vlan2 的 PC 互通 要求 SwitchA 的 vlan3 的 PC 与 SwitchB 的 vlan3 的 PC 互通

3.4.2 数据配置步骤
SwitchA 相关配置: 1. 2.
2009-06-28

创建(进入)vlan2 将 E0/0/1 加入到 vlan2
华为机密,未经许可不得扩散 第 26 页, 共 57 页

[SwitchA] vlan 2

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

[SwitchA-vlan2]port Ethernet 0/0/1

3. 4. 5. 6.

创建(进入)vlan3 将 E0/0/2 加入到 vlan3 实际当中一般将上行端口设置成 trunk 属性,允许 vlan 透传 指定具体的 vlan 值; 也可以允许所有的 vlan 从 E0/3 端口透传通过,

[SwitchA]vlan 3

[SwitchA-vlan3]port Ethernet 0/0/2

[SwitchA-Ethernet0/0/3]port link-type trunk

命令为 port trunk allow-pass vlan all
[SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3

SwitchB 相关配置: 1. 创建(进入)vlan2 将 E0/0/1 加入到 vlan2 创建(进入)vlan3 将 E0/0/2 加入到 vlan3 实际当中一般将上行端口设置成 trunk 属性,允许 vlan 透传 指定具体的 vlan 值;也可以允许所有的 vlan 从 E0/0/3 端口透传通

[SwitchB] vlan 2

2.

[SwitchB-vlan2]port Ethernet 0/0/1

3.

[SwitchB]vlan 3

4.

[SwitchB-vlan3]port Ethernet 0/0/2

5.

[SwitchB-Ethernet0/0/3]port link-type trunk

6.

过,命令为 port trunk allow-pass vlan all
[SwitchB-Ethernet0/0/3] port trunk allow-pass vlan 2 3

?

说明:

(1) vlan 透传转发流程:报文在进入交换机端口时如果没有 802.1Q 标 记将被打上端口的 PVID(即 defauld vlan ID),之后该数据包就只能在 这个 vlan 域内进行转发,不同的 vlan 在二层之间是隔离开的,不能实现 互相访问。 (2) 如果一个端口是 trunk 端口,则该端口可以属于多个 vlan; (3) 缺省情况下 trunk 端口的 PVID 为 1,可以在端口模式下通过命令 port default vlan vlanid 来修改端口的 PVID。

2009-06-28

华为机密,未经许可不得扩散

第 27 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

(4) 如果从 trunk 转发出去的数据报文的 vlan id 和端口的 PVID 一致, 则该报文的 VLAN 信息会被剥去,这点在配置 trunk 端口时需要注意。 (5) 一般情况下最好指定 Trunk 端口允许通过哪些具体的 VLAN, 不要设置允许所有的 VLAN 通过。

3.4.3 测试验证
1. 2. 3. 4. SwitchA vlan2 内的 PC 可以与 SwitchB vlan2 内的 PC 互通 SwitchA vlan3 内的 PC 可以与 SwitchB vlan3 内的 PC 互通 SwitchA vlan2 内的 PC 不能与 SwitchB vlan3 内的 PC 互通 SwitchA vlan3 内的 PC 不能与 SwitchB vlan2 内的 PC 互通

3.5 IP 地址配置
3.5.1 功能需求和组网说明

图3-3 IP 地址配置示意图

配置环境参数: 1. 三层交换机 SwitchA 有两个端口 ethernet 0/0/1、ethernet 0/0/2,分

别属于 vlan 2、vlan 3; 2. 3. 以 vlan 2 的三层接口地址分别是 1.0.0.1/24 作为 PC1 的网关; 以 vlan 3 的三层接口地址分别是 2.0.0.1/24 作为 PC2 的网关;

组网需求: PC1 和 PC2 通过三层接口互通。
2009-06-28 华为机密,未经许可不得扩散 第 28 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.5.2 数据配置步骤
SwitchA 相关配置: 1. 创建(进入)vlan2 将端口 E0/0/1 加入到 vlan2 进入 vlan2 的虚接口 在 vlan2 的虚接口上配置 IP 地址 创建(进入)vlan3 将 E0/0/2 加入到 vlan3 进入 vlan3 的虚接口 在 vlan3 的虚接口上配置 IP 地址

[Quidway]vlan 2

2.

[Quidway-vlan2]port ethernet 0/0/1

3.

[Quidway-vlan2]interface vlan 2

4.

[Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0

5.

[Quidway]vlan 3

6.

[Quidway-vlan3]port ethernet 0/0/2

7.

[Quidway-vlan3]interface vlan 3

8.

[Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0

?

说明:

(1) 二层交换机只能配置一个三层虚接口,三层交换机可以配置多个三 层虚接口。 (2) 三层交换机如果起用了多个三层虚接口, 这个时候多个虚接口之间是 直连路由,所以它们的网段之间默认是直接互通的。如果要实现某些网 段之间的隔离,需要通过配置访问控制列表来实现。 (3) 在配置接口 IP 地址时,一定要确保 IP 地址和网络掩码的正确性。

3.5.3 测试验证
1. PC1 和 PC2 都可以 PING 通自己的网关 2. PC1 和 PC2 可以相互 PING 通

2009-06-28

华为机密,未经许可不得扩散

第 29 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.6 远程维护登录帐号/口令和 Super 密码配置
3.6.1 远程维护登录帐号/口令配置
要求用户从 VTY telnet 登录时输入已配置的帐号和对应的口令,用户名 和口令正确才能登录成功。本例中帐号为 huawei,口令为 Huawei1。配 置示例如下:
<Quidway>system-view [Quidway]user-interface vty 0 4 // 进入 vty 视图

[Quidway-ui-vty0-4] authentication-mode scheme // 设置 scheme 认证 [Quidway]aaa //进入 aaa 界面

[Quidway-aaa]local-user huawei password cipher Huawei1 // 创建本地帐号“huawei”,设置密码为“Huawei1” [Quidway-aaa] local-user huawei service-type telnet // 设置服务类型为 telnet [Quidway-aaa]quit [Quidway]

3.6.2 Super 密码配置
如果用户以较低级别的身份登录到交换机后,需要切换到较高级别的用 户身份上进行操作,需要输入用户级别的口令。该口令需要事先配置。 Super 密码不要跟登录口令一样。本例中 Super 密码设置为 Quidway1。 配置示例如下:
<Quidway>system-view [Quidway]super password level 3 cipher Quidway1

在 Monitor 级视图使用 super 命令验证配置,示例如下:
< Quidway >super Password: Now user privilege is 3 level,and only those commands whose level is equal to or less than this level can be used. Privilege note: 0-VISIT, 1-MONITOR, 2-SYSTEM, 3-MANAGE < Quidway >

2009-06-28

华为机密,未经许可不得扩散

第 30 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.7 端口汇聚配置
功能需求和组网说明

图3-4 端口汇聚配置示意图

配置环境参数: 1. 2. 交换机 SwitchA 和 SwitchB 通过以太网口实现互连。 SwitchA 用于互连的端口为 e0/0/1 和 e0/0/2,SwitchB 用于互连的

端口为 e0/0/1 和 e0/0/2。 组网需求: 增加 SwitchA 的 SwitchB 的互连链路的带宽,并且能够实现链路备份, 使用端口汇聚。

数据配置步骤 SwitchA 交换机配置: 1. 创建汇聚端口 Eth-trunk
[SwitchA]interface Eth-trunk 1

2. 进入端口 E0/0/1
[SwitchA]interface Ethernet 0/0/1

3.

删除端口上默认配置

[SwitchA-Ethernet0/0/1]undo port default vlan 1 [SwitchA-Ethernet0/0/1]bpdu disable [SwitchA-Ethernet0/0/1]undo ntdp enable [SwitchA-Ethernet0/0/1]undo ndp enable

4.

关闭端口,将端口加入 Eth-trunk,打开端口(否则可能会出现流量

中断或短暂广播风暴的现象)
[SwitchA-Ethernet0/0/1]shutdown [SwitchA-Ethernet0/0/1]eth-trunk 1 [SwitchA-Ethernet0/0/1]undo shutdown

5.
2009-06-28

进入端口 E0/0/2
华为机密,未经许可不得扩散 第 31 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

[SwitchA]interface Ethernet 0/0/2

6. 删除端口上默认配置
[SwitchA-Ethernet0/0/2]undo port default vlan 1 [SwitchA-Ethernet0/0/2]bpdu disable [SwitchA-Ethernet0/0/2]undo ntdp enable [SwitchA-Ethernet0/0/2]undo ndp enable

7.

关闭端口,将端口加入 Eth-trunk,打开端口

[SwitchA-Ethernet0/0/2]shutdown [SwitchA-Ethernet0/0/2]eth-trunk 1 [SwitchA-Ethernet0/0/2]undo shutdown

SwitchB 交换机配置:
[SwitchB]interface Eth-trunk 1 [SwitchB]interface Ethernet 0/1 [SwitchB-Ethernet0/1]undo port default vlan 1 [SwitchB-Ethernet0/1]bpdu disable [SwitchB-Ethernet0/1]undo ntdp enable [SwitchB-Ethernet0/1]undo ndp enable [SwitchB-Ethernet0/1]shutdown [SwitchB-Ethernet0/1]eth-trunk 1 [SwitchB-Ethernet0/1]undo shutdown [SwitchB]interface Ethernet 0/2 [SwitchB-Ethernet0/2]undo port default vlan 1 [SwitchB-Ethernet0/2]bpdu disable [SwitchB-Ethernet0/2]undo ntdp enable [SwitchB-Ethernet0/2]undo ndp enable [SwitchB-Ethernet0/2]shutdown [SwitchB-Ethernet0/2]eth-trunk 1 [SwitchB-Ethernet0/2]undo shutdown

?

说明:

(1) 修改 Eth-Trunk 的属性,它的所有成员接口的对应属性也相应改变。 (2) S3300/S5300 以太网交换机最多支持 20 个汇聚组, 1 个汇聚组最多可以 有 8 个端口。 S9300 以太网交换机最多支持 128 个端口汇聚组。1 个汇聚组最多可以 有 8 个端口。S9300 支持跨板 Eth-Trunk,即不同单板中的接口可以捆绑 为一个 Eth-Trunk 接口。
2009-06-28 华为机密,未经许可不得扩散 第 32 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

测试验证 交换机执行 display trunkmembership eth-trunk id 可以显示配置后以 太网端口汇聚情况,通过查看显示信息验证配置的效果。 举例如下:
# 显示该汇聚端口的信息。 <Quidway> display trunkmembership eth-trunk 8 Trunk ID: 8 used status: VALID TYPE: ethernet Working Mode : Static Number Of Ports in Trunk = 3 Number Of UP Ports in Trunk = 3 operate status: up Interface GigabitEthernet0/0/2, up,weight=1,standby interface NULL valid,selected,operate

Interface GigabitEthernet0/0/4, up,weight=1,standby interface NULL

valid,selected,operate

Interface GigabitEthernet0/0/6, up,weight=1,standby interface NULL

valid,selected,operate

3.8 镜像配置
端口镜像,即能将指定端口的数据包复制到监控端口,以进行网络检测 和故障排除。 Quidway 交换机的镜像有几种不同方式: ? 基于端口的镜像 —— 基于端口的镜像是把被镜像端口的进出数据 报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。 ? 基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个 连接都有两个方向的数据流,对于交换机来说这两个数据流是要分 开镜像的,在本指导书中不做详细介绍。

2009-06-28

华为机密,未经许可不得扩散

第 33 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

功能需求和组网说明

图3-5 镜像配置示意图

通过一个 Server 对两台 PC 的报文进行监控。 组网图如下所示。 一台 PC 从端口 E0/0/1 接入, 另一台 PC 从端口 E0/0/2 接入, Server 接在交换机 Ethernet0/0/8。 数据配置步骤
# 定义监控端口,对 PC 之间的通信报文进行监控,监控端口设置为 Ethernet0/0/8 [Quidway] observing-port 1 interface Ethernet0/0/8 //////(1 表示观察接口索引,取值为 1-4) # 定义镜像端口,与监控端口绑定 [Quidway] interface ethernet 0/0/1 [Quidway-Ethernet0/0/1]port-mirroring to observe-port 1 both [Quidway] interface ethernet 0/0/2 [Quidway-Ethernet0/0/2]port-mirroring to observe-port 1 both

?

说明:

1、端口镜像就是复制一份从镜像接口流经的报文,并将此报文传送到指 定的观察接口,因此为了确保镜像过程中信息不丢失,建议观察接口和 被观察接口同类型、同带宽。 在 S-switch 上,端口镜像是通过二层交换芯片的镜像功能实现的,镜像 到指定观察接口上的报文可以实现二层、三层头和数据的内容不变。 2、在 S9300 交换机上,命令行与 S3300/S5300 稍有不同,S3300 上的 port-mirroring to observe-port 在 S9300 上是 port-mirroring observe-port 测试验证 在观测端口上通过工具软件可以看到被镜像端口的相应的报文,可以进 行流量观测或者故障定位。

2009-06-28

华为机密,未经许可不得扩散

第 34 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.9 生成树配置
生成树协议是一种二层管理协议。它通过有选择性地阻塞网络冗余链路 来达到消除网络二层环路的目的,同时具备了链路的备份功能。本节不 以实例进行描述生成树配置,通过对 2.4.6 进行命令行补充。

3.9.1 交换机启动生成树 STP
华为 Quidway 交换机默认没有启用生成树,为了避免交换环路,需要手 工启用生成树协议(STP)。 系统视图命令:stp enable

3.9.2 指定生成树类型
华为 Quidway 交换机默认启用 MSTP 类型,如果需要运用其他类型,需 要手工修改。 系统视图命令:stp mode mstp

3.9.3 指定生成树主根和备根
系统视图命令: 生成树主根命令:stp root primary 生成树备根命令:stp root secondary

3.9.4 对主备交换机级联接口调整端口路径花销
以太网端口视图命令:stp cost cost

3.9.5 与主机互联的端口配置为边缘端口
所有确定与主机互联的端口都应配置为 edged-port,这样的配置有利于 主机与网络设备的稳定快速的协商,减少不必要的网络流量,也大大减 轻了网络设备计算 STP 的资源消耗。对连接到 SCP 等主机设备和路由 器设备设置为 edged-port,其他的端口(如连接到 USAU HSC 板、交换 机级联不要配)。 以太网接口视图命令:stp edged-port enable

3.9.6 三层 VLAN 点对点方式互联端口关闭 STP 协议
以太网接口视图命令:stp disable
2009-06-28 第 35 页, 共 57 页

华为机密,未经许可不得扩散

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.10 VRRP 配置
VRRP 配置用于三层交换机。二层交换机无此功能。

3.10.1 功能需求和组网说明

图3-6 VRRP 配置示意图

配置环境参数: SwitchA 通过 E0/0/22 与 SwitchC 相连, SwitchB 通过 E0/0/22 与 SwitchD 相连, SwitchA 和 SwitchB 上创建虚接口,interface vlan 10 做为三层接口,其 中 vlan 10 包含 ethernet 0/0/22 端口。 SwitchC 和 SwitchD 上创建虚接口,interface vlan 10 做为三层接口,其 中 vlan 10 包含 ethernet 0/0/22 端口。 组网需求: SwitchA 和、 SwitchB 与 Switch C、 Switch D 之间做 VRRP, interface vlan 10 做为虚拟网关接口。Switch A 为主设备,允许抢占,SwitchB 为从设 备, VRRP 虚拟地址 192.168.100.1,进行冗余备份;Switch C 为主设 备,允许抢占,SwitchD 为从设备, VRRP 虚拟地址 192.168.100.4, 进行冗余备份;

3.10.2 数据配置步骤
SwitchA 相关配置: 基础配置 1. 创建(进入)vlan10

[SwitchA] vlan 10

2009-06-28

华为机密,未经许可不得扩散

第 36 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

2. 3. 4.

将 E0/0/22 加入到 vlan10 创建(进入)vlan10 的虚接口 给 vlan10 的虚接口配置 IP 地址

[SwitchA-vlan10] port Ethernet 0/0/22

[SwitchA-vlan10]interface vlan 10

[SwitchA-Vlan-interface10]ip add 192.168.100.2 255.255.255.248

VRRP 配置 1. 2. 3. 创建 VRRP 组 1,虚拟网关为 192.168.100.1 设置 VRRP 组优先级为 105,缺省为 100 设置监控端口为 interface vlan 20, 如果端口 Down 掉优先级降低 30

[SwitchA-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.100.1

[SwitchA-Vlan-interface10]vrrp vrid 1 priority 105

[SwitchA-Vlan-interface10] vrrp vrid 1 track interface Vlanif 20 reduced 30

SwitchB 相关配置 基础配置 1. 2. 3. 4. 创建(进入)vlan10 加 E0/0/22 加入到 vlan10 创建(进入)vlan10 的虚接口 给 vlan10 的虚接口配置 IP 地址

[SwitchB] vlan 10

[SwitchB-vlan10] port Ethernet 0/0/22

[SwitchB] interface vlan 10

[SwitchB-Vlan-interface10]ip address 192.168.100.3 255.255.255.248

VRRP 配置 1. 创建 VRRP 组 1,虚拟网关为 192.168.100.1

[SwitchB-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.100.1

【SwitchC 相关配置】 基础配置 1. 创建(进入)vlan10

[SwitchC] vlan 10

2009-06-28

华为机密,未经许可不得扩散

第 37 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

2. 3. 4.

将 E0/0/22 加入到 vlan10 创建(进入)vlan10 的虚接口 给 vlan10 的虚接口配置 IP 地址

[SwitchC-vlan10] port Ethernet 0/0/22

[SwitchC-vlan10]interface vlan 10

[SwitchC-Vlan-interface10]ip add 192.168.100.5 255.255.255.248

VRRP 配置 1. 2. 3. 创建 VRRP 组 1,虚拟网关为 192.168.100.4 设置 VRRP 组优先级为 105,缺省为 100 设置监控端口为 interface vlan 30, 如果端口 Down 掉优先级降低 30

[SwitchC-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.100.4

[SwitchC-Vlan-interface10]vrrp vrid 1 priority 105

[SwitchA-Vlan-interface10] vrrp vrid 1 track interface Vlanif 30 reduced 30

SwitchD 相关配置 基础配置 1. 2. 3. 4. 创建(进入)vlan10 加 E0/0/22 加入到 vlan10 创建(进入)vlan10 的虚接口 给 vlan10 的虚接口配置 IP 地址

[SwitchD] vlan 10

[SwitchD-vlan10] port Ethernet 0/0/22

[SwitchD] interface vlan 10

[SwitchD-Vlan-interface10]ip address 192.168.100.6 255.255.255.248

VRRP 配置 1. 创建 VRRP 组 1,虚拟网关为 192.168.100.4

[SwitchD-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.100.4

?

说明:

(1) S3300/S5300/S9300 默认打开虚拟地址可以被 ping 的功能,若需 要关闭系统视图下配置命令为 undo vrrp virtual-ip ping enable;
2009-06-28 华为机密,未经许可不得扩散 第 38 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

(2) S3300/S5300/S9300 默认打开抢占功能,若需要关闭,接口视图下 命令为 vrrp vrid (vrrp-id) preempt-mode disable

3.10.3 测试验证
将 SwitchA 连接 SwitchB、SwitchC 连接 SwitchD 的链路任意断开一条, 业务仍然正常。

3.11 静态路由配置
3.11.1 功能需求和组网说明

图3-7 路由配置示意图

配置环境参数: 1. 2. 如图,交换机 SwitchA、SwitchB 实现互连。 SwitchA 中 vlan10 虚接口地址 192.168.1.1/24,vlan20 虚接口地址

192.168.0.1/30,vlan20 与 SwitchB vlan20 互连,vlan10 接局域网; 3. SwitchB 中 vlan20 虚接口地址 192.168.0.2/30,vlan30 虚接口地址

192.168.2.1/24,vlan20 与 SwitchA vlan20 互连,vlan30 接局域网; 4. PC1 的 IP 地址为 192.168.1.2/24,网关为 192.168.1.1;PC2 的 IP

地址为 192.168.2.2/24,网关为 192.168.2.1 组网需求: 交换机之间配置静态路由,保证 PC1 和 PC2 互通。

2009-06-28

华为机密,未经许可不得扩散

第 39 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3.11.2 数据配置步骤
SwitchA 相关配置: 1. 创建(进入)vlan10

[SwitchA]vlan 10 [SwitchA-vlan10]port <VLAN 10 的端口>

2. 3. 4.

创建(进入)vlan10 的虚接口 给 vlan10 的虚接口配置 IP 地址 创建(进入)vlan20

[SwitchA] interface vlan 10

[SwitchA-Vlan-interface10]ip address 192.168.1.1 255.255.255.0

[SwitchA]Vlan 20 [SwitchA-vlan10]Port <vlan 20 的端口>

5. 6.

创建(进入)vlan20 的虚接口 给 vlan20 的虚接口配置 IP 地址

[SwitchA]interface vlan 20

[SwitchA-Vlan-interface20] ip address 192.168.0.1 255.255.255.252

7. 配置静态路由
[SwitchA] ip route-static 192.168.2.0 255.255.255.0 192.168.0.2

SwitchB 相关配置: 1. 创建(进入)vlan20

[SwitchB]vlan 20 [SwitchB-vlan20]port <VLAN 20 的端口>

2. 3. 4.

创建(进入)vlan20 的虚接口 给 vlan20 的虚接口配置 IP 地址 创建(进入)vlan30

[SwitchB]interface vlan 20

[SwitchB-Vlan-interface20]ip address 192.168.0.2 255.255.255.252

[SwitchB]vlan 30 [SwitchB-vlan30]port <vlan 30 的端口>

5. 6.

创建(进入)vlan30 的虚接口 给 vlan30 的虚接口配置 IP 地址

[SwitchB-vlan30]interface vlan 30

[SwitchB-Vlan-interface30]ip address 192.168.2.1 255.255.255.0

2009-06-28

华为机密,未经许可不得扩散

第 40 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

7.

配置静态路由

[SwitchB] ip route-static 192.168.1.0 255.255.255.0 192.168.0.1

3.11.3 测试验证
PC1 能够 PING 通 PC2, 在交换机上使用 display ip routing-table 命令可 以看到各个网段路由信息。 注意: (1) (2) 在配置完成并验证配置正确后,请在用户视图使用 save 命令保存 配置。 删除命令使用 undo 命令。

3.12 OSPF 配置
3.12.1 功能需求和组网说明

图3-8 OSPF 配置示意图

配置环境参数: 1、 如图,要求全网互连互通,所有网段都能访问 Internet 业务; 2、 SW1-SW4 配置 loopback 地址,地址命名为:X.X.X.X(X 代表 交换机序号,例如:SW1 的 loopback 地址为 1.1.1.1,SW2 的 loopback 地址为 2.2.2.2);

2009-06-28

华为机密,未经许可不得扩散

第 41 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3、 SW1-SW4 为全网的核心交换机,放置在 Area 0 域内;SW1、 SW2 分别和做了双机的防火墙相连,在 SW1 和 SW2 上分别设 置了默认路由指向防火墙的 VRRP 地址; 4、 ATAE SW1-SW4 上的 4 个 vlan 131-134 的业务网关都配置为 SW3、SW4 上这几个 vlan 的 VRRP 浮动地址; 5、 SW1-SW4 上 4 个 vlan 110、 120、 130、 140 的地址置于 Area 0 内,SW1、SW2 之间的互联链路设置为 trunk,允许 vlan 140、 150 通过;SW3、SW4 之间的互联链路设置为 trunk,允许 5 个 vlan 130-134 通过; 6、 Vlan 131:192.168.1.0/25 Vlan 132:192.168.1.128/25 Vlan 133:192.168.2.0/25 Vlan 134:192.168.2.128/25 Vlan 110:10.10.10.4/30 Vlan 120:10.10.10.8/30 Vlan 130:10.10.10.12/30 Vlan 140:10.10.10.0/30 Vlan 150:10.10.10.16/29 组网需求:使用动态路由协议将全网连通,同时所有设备要求能访 问 Internet 业务。

3.12.2 数据配置步骤
准备配置: SW1 配置: 1、配置接口 vlan
Interface vlan 110 Ip address 10.10.10.5 255.255.255.252 Interface vlan 140 Ip address 10.10.10.1 255.255.255.252

2、配置 VRRP
Interface vlan 150 Ip address 10.10.10.18 255.255.255.248 Vrrp vrid 1 virtual-ip 10.10.10.17 Vrrp vrid 1 priority 105

2009-06-28

华为机密,未经许可不得扩散

第 42 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

3、配置 Trunk 链路:
Interface ethernet 0/0/24 Port link-type trunk Port trunk allow-pass vlan 140 150

SW2 配置: 1、配置接口 vlan
Interface vlan 120 Ip address 10.10.10.9 255.255.255.252 Interface vlan 140 Ip address 10.10.10.2 255.255.255.252

2、配置 VRRP
Interface vlan 150 Ip address 10.10.10.19 255.255.255.248 Vrrp vrid 1 virtual-ip 10.10.10.17

3、配置 Trunk 链路:
Interface ethernet 0/0/24 Port link-type trunk Port trunk allow-pass vlan 140 150

SW3 配置: 1、配置接口 vlan
Interface vlan 110 Ip address 10.10.10.6 255.255.255.252 Interface vlan 130 Ip address 10.10.10.13 255.255.255.252

2、配置 VRRP
Interface vlan 131 Ip address 192.168.1.124 Vrrp vrid 2 virtual-ip 192.168.1.126 Vrrp vrid 2 priority 105 Interface vlan 132 Ip address 192.168.1.252 Vrrp vrid 3 virtual-ip 192.168.1.254 Vrrp vrid 3 priority 105 Interface vlan 133 Ip address 192.168.2.124

2009-06-28

华为机密,未经许可不得扩散

第 43 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Vrrp vrid 4 virtual-ip 192.168.2.126 Vrrp vrid 4 priority 105 Interface vlan 134 Ip address 192.168.2.252 Vrrp vrid 5 virtual-ip 192.168.2.254 Vrrp vrid 5 priority 105

3、配置 Trunk 链路:
Interface ethernet 0/0/24 Port link-type trunk Port trunk allow-pass vlan 130 to 134

SW4 配置: 1、配置接口 vlan
Interface vlan 120 Ip address 10.10.10.10 255.255.255.252 Interface vlan 130 Ip address 10.10.10.14 255.255.255.252

2、配置 VRRP
Interface vlan 131 Ip address 192.168.1.124 Vrrp vrid 2 virtual-ip 192.168.1.126 Interface vlan 132 Ip address 192.168.1.252 Vrrp vrid 3 virtual-ip 192.168.1.254 Interface vlan 133 Ip address 192.168.2.124 Vrrp vrid 4 virtual-ip 192.168.2.126 Interface vlan 134 Ip address 192.168.2.252 Vrrp vrid 5 virtual-ip 192.168.2.254

3、配置 Trunk 链路:
Interface ethernet 0/0/24 Port link-type trunk Port trunk allow-pass vlan 130 to 134

OSPF 配置: SW1 配置:
2009-06-28 华为机密,未经许可不得扩散 第 44 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

1、 配置设备 loopback 地址
[SW1]interface loopback0 [SW1-Loopback0]ip address 1.1.1.1 255.255.255.255

2、 启用 OSPF 路由协议
[SW1]ospf [process]

3、 配置设备 Route-id
[SW1]ospf route-id 1.1.1.1

4、 发布网段
[SW1-ospf]area 0 [SW1-ospf-area-0.0.0.0]network 10.10.10.0 0.0.0.3 [SW1-ospf-area-0.0.0.0]network 10.10.10.4 0.0.0.3 [SW1-ospf-area-0.0.0.0]network 1.1.1.1 0.0.0.0

5、 配置默认路由
[SW1]ip route-static 0.0.0.0 0.0.0.0 10.10.10.20

6、 将默认路由发布到 OSPF 中
[SW1-ospf] default-route-advertise

SW2 相关配置: 1、 配置设备 loopback 地址
[SW2]interface loopback0 [SW2-Loopback0]ip address 2.2.2.2 255.255.255.255

2、 启用 OSPF 路由协议
[SW2]ospf [process]

3、 配置设备 Route-id
[SW2]ospf route-id 2.2.2.2

4、 发布网段
[SW2-ospf]area 0 [SW2-ospf-area-0.0.0.0]network 10.10.10.0 0.0.0.3 [SW2-ospf-area-0.0.0.0]network 10.10.10.8 0.0.0.3 [SW2-ospf-area-0.0.0.0]network 2.2.2.2 0.0.0.0

5、 配置默认路由
[SW21]ip route-static 0.0.0.0 0.0.0.0 10.10.10.20

6、 将默认路由发布到 OSPF 中
[SW2-ospf] default-route-advertise

2009-06-28

华为机密,未经许可不得扩散

第 45 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

SW3 相关配置: 1、 配置设备 loopback 地址
[SW3]interface loopback0 [SW3-Loopback0]ip address 3.3.3.3 255.255.255.255

2、 启用 OSPF 路由协议
[SW3]ospf [process]

3、 配置设备 Route-id
[SW3]ospf route-id 3.3.3.3

4、 发布网段
[SW3-ospf]area 0 [SW3-ospf-area-0.0.0.0]network 10.10.10.4 0.0.0.3 [SW3-ospf-area-0.0.0.0]network 10.10.10.12 0.0.0.3 [SW3-ospf-area-0.0.0.0]network 3.3.3.3 0.0.0.0

5、 将直连路由重分布到 OSPF
[SW3-ospf]import-route direct

SW4 相关配置: 1、 配置设备 loopback 地址
[SW4] interface loopback0 [SW4-Loopback0]ip address 4.4.4.4 255.255.255.255

2、 启用 OSPF 路由协议
[SW4]ospf [process]

3、 配置设备 Route-id
[SW4]ospf route-id 4.4.4.4

4、 发布网段
[SW4-ospf]area 0 [SW4-ospf-area-0.0.0.0]network 10.10.10.8 0.0.0.3 [SW4-ospf-area-0.0.0.0]network 10.10.10.12 0.0.0.3 [SW4-ospf-area-0.0.0.0]network 4.4.4.4 0.0.0.0

5、 将直连路由重分布到 OSPF
[SW3-ospf]import-route direct

注意: A、 S3300/S5300/S9300 支持 OSPF 多进程,即在一台交换机上可以配 置 多 个 OSPF , 每 个 进 程 都 是 独 立 的 OSPF , 命 令 为 ospf (processor-id).
2009-06-28 华为机密,未经许可不得扩散 第 46 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

B、 导入路由的命令为: import-route protocol [cost value] [type value] 1、 protocol:可引入的源路由协议,目前可为 direct、bgp、static、rip、 isis、ospf、ospf-ase、ospf-nssa 2、 cost value:引入路由的 cost 值。缺省情况下,cost 为 1。主要用于 优选路由。 3、 type value : 指定 OSPF 在引入其它协议路由时的路由类型,value 的取值为 1 或 2,type 1 为第一类外部路由,type 2 为第二类外部路 由, 缺省为 type 2。 第一类外部路由是指接收的是例如 RIP, STATIC, DIRECT 等的路由,这些路由在重分发到 OSPF 时的 COST 值是本 路由器到相应的自治系统边界路由器的花费值与自治系统边界路由 器到该路由目的地址的花费值之和。第二类外部路由是指接收的是 BGP 路由,这类路由重分发到 OSPG 的花费值就等于自治系统边界 路由器到该路由目的地址的花费值。

3.12.3 测试验证
所有网段 PC 机均能访问 Internet 业务, 使用 display ospf peer 命令查看 是否所有交换机都建立好邻居关系,同时在每台运行 OSPF 的交换机上 使用 display ospf routing 查看交换机的路由表。 注意: (1) (2) (3) 查看交换机路由表时因尤其注意默认路由的发布。 在配置完成并验证配置正确后,请在用户视图使用 save 命令保存 配置。 删除命令使用 undo 命令。

第4章 Quidway 局域网交换机基本维护
4.1 查看软件版本信息
display version 命令用来显示系统版本信息。通过查看版本信息,可以 获知系统当前使用的软件版本、机架类型、主控板及接口板的相关信息。 查看当前的软件版本是进行软件升级,定位问题的前提。 命令举例参见 2.2.1

2009-06-28

华为机密,未经许可不得扩散

第 47 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.2 系统配置文件维护
display current-configuration 命令用来显示交换机当前的配置。 display saved-configuration 命令用来显示保存的交换机配置,也是交 换机下次上电启动时,所用的配置。 save [ safely ] 命令用来保存当前配置信息到存储设备中。缺省方式 下,采用快速保存模式,不带 safely 参数。对于电源稳定程度较好的环 境,推荐使用默认的快速模式。对于电源环境恶劣,或者远程维护等情 况,推荐使用带有 safely 参数的保存配置命令。 reset saved-configuration 命令用来擦除保存的交换机配置。慎重执行 该命令,最好在技术支持人员指导下使用。 display diagnostic-information 命令用来显示交换机的诊断信息。

4.3 查看 CPU 占用率
display cpu 命令用来显示 CPU 占用率的统计信息。 CPU 占有率应正常, 与当前开展的业务类型和转发流量相符。在正常情况下 CPU 占有率 <50%。 命令举例如下:
<Quidway> dis cpu-usage CPU Usage Stat. Cycle: 5 (Second) CPU Usage : 9% Max: 100%

CPU Usage Stat. Time : 2009-06-22 10:37:55 CPU Usage Stat. Tick : 0x2824(CPU Tick High) 0x7e671873(CPU Tick Low) Actual Stat. Cycle TaskName BUFM VIDL TICK RMON RPCQ STND bcmL2X.0 bcmCNTR.0 bcmTX INFO SRM SMLK : 0x0(CPU Tick High) 0x2ada41b9(CPU Tick Low) CPU 0% 91% 0% 0% 0% 0% 0% 0% 0% 0% 4% 0% Runtime(CPU Tick High/CPU Tick Low) 0/ b1290

0/25830ecf 0/ 4131a8 0/ 8cc7

0/ 19ec80 0/ 1da5f

0/ 50b6d4 0/ 1d4447 0/ 0/ 1b2cd 3eff

0/ 1bdbd92 0/ 6ff3

2009-06-28

华为机密,未经许可不得扩散

第 48 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

L2IF BFD ROUT STRM DH1 FTPS VTYD vt0 TRUN NTPT AUTH EAP MACA TAC UCM MSTP RRPP SRMT CLST NTDP NDP VRRP IGMP SNMP EFM EOAM L3MC LLDP ICMP SOCK OS

0% 0% 1% 0% 0% 0% 0% 1% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 0% 3%

0/ 0/

6a206 5ddec

0/ 810b43 0/ 0/ 6e6e 1a1ac

0/ 611910 0/ 982b0

0/ b70e47 0/ e02eb

0/ 216f5d 0/ 0/ 0/ 0/ 0/ 0/ 0/ 851 eb0f 9093 533ba 2783 6202 bf415

0/ 2d5ffd 0/ f4981

0/ 476acb 0/ 0/ 0/ 0/ 0/ 0/ 0/ 0/ 0/ 14963 69f 5fd3 eef3c 0 0 0 0 0

0/ 172f2c 0/ 20b135

4.4 查看内存占用率
display memory 命令用来显示系统内存使用情况。内存占有率不应过 高。在正常情况下内存占有率<80%。 命令举例如下:
<Quidway> dis memory-usage Memory utilization statistics at 2009-06-22 10:38:43 140 ms System Total Memory Is: 72998368 bytes

2009-06-28

华为机密,未经许可不得扩散

第 49 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Total Memory Used Is: 39061548 bytes Memory Using Percentage Is: 53%

4.5 查看日志缓冲区信息
display logbuffer 命令用来显示日志缓冲区记录的信息。正常情况下, 日志中不应该有大量重复的信息。重复的信息:比如端口频繁 up/down, 大量用户认证失败信息等。 命令举例如下:
<Quidway>display logbuffer Logging buffer configuration and contents:enabled Allowed max buffer size : 1024 Actual buffer size : 512 Channel number : 4 , Channel name : logbuffer Dropped messages : 0 Overwritten messages : 0 Current messages : 46

Jun 22 2009 10:37:47 S3300 %%01HWCM/4/EXIT(l): Exit from configure mode. Jun 22 2009 09:55:11 S3300 %%01CMD/4/SUPERLOGIN(l): User: huawei address: 10.76.160.151 level: 3 login: Successful. IP

Jun 22 2009 09:55:05 S3300 %%01SHELL/4/TELNETFAILED(l): Login through telnet failed( ip=10.76.160.151 times=1). Jun 21 2009 14:41:57 S3300 %%01FIB/3/REFRESH_END(l): FIB refreshing end, the refresh group map is 0! Jun 21 2009 14:41:54 S3300 %%01FIB/3/REFRESH_START(l): FIB

refreshing start, the refresh group map is 4294967295! Jun 20 2009 14:41:57 S3300 %%01FIB/3/REFRESH_END(l): FIB refreshing end, the refresh group map is 0! Jun 20 2009 14:41:54 S3300 %%01FIB/3/REFRESH_START(l): FIB

refreshing start, the refresh group map is 4294967295! Jun 19 2009 18:03:25 S3300 %%01SOCKET/4/SOCK_TCPDETAILLOG(l):

Detailed information on the current tcp socket: State: Last_Ack, local-ip: 10.69.18.33, local-port: 23, remote-ip: 10.76.160.151, remote-port: 1499.

2009-06-28

华为机密,未经许可不得扩散

第 50 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.6 查看路由表信息
display ip routing-table 命令用来查看路由表信息。该命令显示路由 表信息每一行代表一条路由,内容包括:目的地址/掩码长度、协议、优 先级、度量值、下一跳、输出接口。 使用 display ip routing-table 命令仅能查看到当前被使用的路由。在 检查路由表时,路由表不应有无效路由、失效路由。 命令举例如下:
<Quidway> <S3300>display ip routing-table

如果使用了 OSPF 动态路由协议,还应当使用 display ospf routing 查看 OSPF 路由表。

4.7 查看 OSPF 状态
1. 查看 OSPF 邻居是否正常。display ospf peer. (1) 状态为 Full(State: Full)--正常。 (2) 状态为 DOWN 或者看不到状态--无法收到对端 HELLO 报文。 (3) 状态为 INIT,--表示能收到对端 HELLO 报文。但对端报文中没有包 含本设备的信息。(对端无法收到本端 OSPF 的 HELLO 报文)。 2. 基本配置是否正确 (1) 一个域内是否有相同的 ID 设备--看 dis osp err 中 confusion (2) 域 ID 错误---OSPF: wrong area id mismatch HELLO: router id

(3) NETWORK 掩码不一致--HELLO: netmask (4) 修改 OSPF 参数后要复位 OSPF。
2009-06-28 华为机密,未经许可不得扩散

第 51 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.8 查看接口状态
display interface 命令用来显示接口当前的运行状态和相关信息。 使用 display interface 命令查看接口工作模式。对于以太网接口操作 模式(包括速率、双工)对接双方必须一致。端口速率、双工默认为自 协商模式,建议不作改动。当在设备经过一段时间运行之后,接口 collisions 和 late collisions 统计应为 0,否则可能存在接口工作不 一致现象或者工作在半双工模式(在半双工模式下存在少量 collisions 是正常的)。手动指定速率双工配置时,必须两端配置保持一致。 查看各个使用的接口收发统计数据是否正常,异常报文是否有增长。建 议 display interface 命令多次执行,每次间隔一定时间,正常情况下, 端口错包统计不应该有变化。常见端口状态基线:CRC 出错率<10 ,冲突 比率<0.1%,接收广播和组播比率<10%(跟应用相关,如果某些应用为组 播应用,该比率需要适当调整)。 命令举例如下:
<S3300>dis inter Ethernet0/0/1 Ethernet0/0/1 current state : UP Description : Huawei, Quidway Series, Ethernet0/0/1 Interface, Switch Port PVID : 1
-6

The Maximum Transmit Unit is 1500 bytes Internet protocol processing : disabled IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 0018-82a9-3f24 AUTO NEGOTIATION, SPEED 100M, DUPLEX FULL, LOOPBACK NOT SET; Transmitter's pause : disable, Receiver's pause : disable ; Last 300 seconds input rate: 9472 bits/sec, 16 packets/sec Last 300 seconds output rate: 216 bits/sec, 0 packets/sec Last 300 seconds Multicast input rate: 0 packets/sec Last 300 seconds Multicast output rate: 0 packets/sec Input: 7028842 Packets, 493913120 Bytes 1744459 Broadcasts, 177696 Multicasts 0 Oversizes, 0 Undersizes 0 FCSs, 0 Pauses Output: 70572 Packets, 5539661 Bytes 2249 Broadcasts, 5529 Multicasts 0 Oversizes, 0 Defers 0 FCSs, 0 Pauses 0 Collisions

2009-06-28

华为机密,未经许可不得扩散

第 52 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.9 查看 MAC 地址表
display mac-address 命令用来显示 MAC 地址和端口的映射信息。 管理员管理交换机二层地址时可以用此命令查看二层地址表、地址状态 (静态还是动态)、地址所在以太网口、地址所在 VLAN、系统地址老化 时间等信息。 命令举例如下:
<S3300>display mac-address MAC Address VLAN/VSI Port Type Lsp

---------------------------------------------------------------0018-8252-b054 0021-7099-9cca 000f-e25c-6fe1 0002-55df-c3b9 0018-825d-9a8c 0018-82e1-55ac 000f-e257-ff38 00e0-fc7f-95f7 001e-ec7b-cf7d 1 1 1 1 1 1 1 1 1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 Ethernet0/0/1 dynamic dynamic dynamic dynamic dynamic dynamic dynamic dynamic dynamic 0/0 0/0 0/0 0/0 0/0 0/0 0/0 0/0 0/0

4.10 查看 ARP 映射表
display arp 命令用来显示 ARP 映射表(IP 地址和 MAC 地址映射表)。 该命令主要用于分析在以太网接口中 IP 地址和 MAC 地址映射表对应关 系, 有助于分析双机浮动 IP 地址和 MAC 地址对应关系和设备的连接信息。 命令举例如下:
<S3300>display arp

2009-06-28

华为机密,未经许可不得扩散

第 53 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.11 查看 VLAN 信息
display vlan 命令用来显示 VLAN 的个数。 命令举例如下:
<S3300>display vlan VLAN ID Type Status MAC Learning

---------------------------------------------------------1 2 3 common common common enable enable enable enable enable enable

Total vlan displayed = 3

display vlan (1-4096)用于查看指定 VLAN,显示这个 VLAN 的相关 信息, 包括: VLAN ID、 状态、 TRUNK 是否允许该 VLAN 通过、 该 VLAN 包含哪些端口,所包含端口的状态等。 命令举例如下:
<S3300>display vlan 1 VLAN ID Type Status MAC Learning

---------------------------------------------------------1 common enable enable

---------------Untagged Port: Ethernet0/0/1 GigabitEthernet0/0/2 Ethernet0/0/4 Ethernet0/0/5 Ethernet0/0/7 Ethernet0/0/9 Ethernet0/0/11 Ethernet0/0/13 Ethernet0/0/15 Ethernet0/0/18 Ethernet0/0/20 Ethernet0/0/22 Ethernet0/0/24 ---------------Tagged Port: Eth-Trunk1 GigabitEthernet0/0/1 GigabitEthernet0/0/3 GigabitEthernet0/0/4 Ethernet0/0/6 Ethernet0/0/8 Ethernet0/0/10 Ethernet0/0/12 Ethernet0/0/14 Ethernet0/0/17 Ethernet0/0/19 Ethernet0/0/21 Ethernet0/0/23

---------------Interface Eth-Trunk1 Physical DOWN

2009-06-28

华为机密,未经许可不得扩散

第 54 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

Ethernet0/0/1 GigabitEthernet0/0/1 GigabitEthernet0/0/2 GigabitEthernet0/0/3 Ethernet0/0/4 GigabitEthernet0/0/4 Ethernet0/0/5 Ethernet0/0/6 Ethernet0/0/7 Ethernet0/0/8 Ethernet0/0/9 Ethernet0/0/10 Ethernet0/0/11 Ethernet0/0/12 Ethernet0/0/13 Ethernet0/0/14 Ethernet0/0/15 Ethernet0/0/17 Ethernet0/0/18 Ethernet0/0/19 Ethernet0/0/20 Ethernet0/0/21 Ethernet0/0/22 Ethernet0/0/23 Ethernet0/0/24

UP DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN DOWN

4.12 查看生成树信息
display stp 命令用来显示生成树的状态信息与统计信息。 查看生成树配置时,STP 的 TCN(拓扑变化数目)数目应该保持稳定,不是 持续增长状态;有连接环路应存在端口处于 DISCARDING 状态,不转发报 文。 命令举例如下:
[S3300]display stp -------[CIST Global Info][Mode MSTP]------CIST Bridge Bridge Times CIST Root/ERPC CIST RegRoot/IRPC CIST RootPortId :32768.0018-82a9-3f24 :Hello 2s MaxAge 20s FwDly 15s MaxHop 20 :0 .00e0-fc18-9529 / 199999

:32768.0018-82a9-3f24 / 0 :128.66

2009-06-28

华为机密,未经许可不得扩散

第 55 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

BPDU-Protection

:disabled

TC or TCN received :0 STP Converge Mode :Fast

Time since last TC received :3 days 20h:37m:52s

----[Port1(Ethernet0/0/1)][FORWARDING]---Port Protocol Port Role Port Priority Port Cost(Dot1T ) Desg. Bridge/Port Port Edged Point-to-point Transit Limit Protection Type :enabled :CIST Root Port :128 :Config=auto / Active=199999 :0.00e0-fc18-9529 / 128.1 :Config=disabled / Active=disabled :Config=auto / Active=true :3 packets/hello-time :None

Port Protocol Type :Config=auto / Active=legacy PortTimes BPDU Sent :Hello 2s MaxAge 20s FwDly 15s RemHop 0 :6

TCN: 0, Config: 0, RST: 0, MST: 6 BPDU Received :18

TCN: 0, Config: 0, RST: 0, MST: 18

----[Port4(Ethernet0/0/4)][DOWN]---Port Protocol Port Role Port Priority Port Cost(Dot1T ) Desg. Bridge/Port Port Edged Point-to-point Transit Limit Protection Type Port Stp Mode :enabled :CIST Disabled Port :128 :Config=auto / Active=199999 :32768.0018-82a9-3f24 / 128.69 :Config=disabled / Active=disabled :Config=auto / Active=false :3 packets/hello-time :None :Stp

Port Protocol Type :Config=auto / Active=legacy PortTimes BPDU Sent :Hello 2s MaxAge 20s FwDly 15s RemHop 0 :0

TCN: 0, Config: 0, RST: 0, MST: 0 BPDU Received :0

TCN: 0, Config: 0, RST: 0, MST: 0

2009-06-28

华为机密,未经许可不得扩散

第 56 页, 共 57 页

Quidway 自研以太网交换机开局指导书 V1.0-20090625-B1

内部公开

4.13 查看 VRRP 信息
display vrrp 命令用来显示 vrrp 的相关信息。信息包括 VRRP 的状态、 Virtual IP 的地址、优先级、是否配置抢占等。 命令举例如下:
[S3300]dis vrrp Vlanif2 | Virtual Router 1 state : Initialize Virtual IP : 1.1.1.2 PriorityRun : 100 PriorityConfig : 100 MasterPriority : 0 Preempt : YES Timer : 1 Auth Type : NONE Check TTL : YES Delay Time : 0

4.14 收集系统诊断信息
display diagnostic-information 命令用来显示系统当前各模块的运行 信息。 在系统出现故障时,为了便于问题定位,需要收集很多的信息,但相应 的 display 命令很多,很难一次把信息收集全,这时,可以使用 display diagnostic-information 命令, 进行系统当前各个模块的运行信息收集。 display diagnostic-information 命令主要收集设备版本、当前配置、 接口、路由表、日志缓存、内存、CPU、MAC 地址表、ARP、VLAN、生成树、 设备异常和历史命令清单等信息。

2009-06-28

华为机密,未经许可不得扩散

第 57 页, 共 57 页


相关文档

Quidway自研以太网交换机开局指导书V1.0-20090625-B1
Quidway防火墙 Eudemon1000E 开局指导书V1[1].0-20091025-B1
华为3COM WLAN Uranus产品开局配置指导书v1_0
GSM干扰分析指导书(V1[1].0华为)
GSM干扰分析指导书(V1[1][1].0华为)
HUAWEI BTS3012 II开局指导书
Quidway以太网交换机上机指导书ISSUE1.0
华为QUIDWAY3900 系列华为交换机操作手册---23-ARP操作
电脑版